Back to overview
Resolved

USxS

Jun 25, 2026 at 11:45am UTC
Affected services
USxS

Resolved
Jun 25, 2026 at 5:15pm UTC

The issue impacting USxS has been resolved, and services have been restored. Our team will continue to monitor to ensure stability. Should you still be experiencing a problem please contact NEOnet as soon as possible. Thank you for your patience while we worked to resolve this issue.

Updated
Jun 25, 2026 at 2:51pm UTC

NEOnet has implemented a workaround to help restore access to USxS as quickly as possible. Most districts should now be able to access the system.

We are aware that a small number of districts are still experiencing issues. NEOnet is manually updating those databases to complete the restoration process. We will continue to provide updates as additional information becomes available.

Thank you for your patience while this issue is being resolved.

Created
Jun 25, 2026 at 11:45am UTC

NEOnet is currently experiencing an issue impacting USxS. Our team is actively working toward resolution. Updates will be provided at regular intervals, and a final notification will be sent once service is restored.