Back to overview
Resolved
eFP Workflow Notifications & Task Alerts
Jun 3, 2026 at 4:00pm UTC
Affected services
eFP
Resolved
Jun 3, 2026 at 4:15pm UTC
The issue impacting eFP Report Generation has been resolved, and services have been restored. Our team will continue to monitor to ensure stability. Should you still be experiencing a problem please contact NEOnet as soon as possible. Thank you for your patience while we worked to resolve this issue.
Root Cause: PowerSchool identified the cause as the server needing additional space and was able to address it within about 15 minutes of it being reported.
Affected services
Created
Jun 3, 2026 at 4:00pm UTC
NEOnet is currently experiencing an issue impacting eFP report generation. Our team is actively working with the MCOECN toward resolution.
Affected services