GradeBook – Falls Region - Performance Degradation
Resolved
Aug 20, 2026 at 2:45pm UTC
Resolved – Falls GradeBook Performance
The slowness impacting Falls GradeBook has been resolved, and the system has returned to normal performance.
NEOnet worked with Frontline to identify and address the issue. Users should no longer experience slower-than-normal performance.
Thank you for your patience while we worked to resolve this issue.
Affected services
Created
Aug 20, 2026 at 12:15pm UTC
NEOnet is currently experiencing slowness impacting Falls GradeBook. The system remains functional, but users may experience slower-than-normal performance.
Our team is actively working with Frontline to identify the cause and work toward a resolution. A final notice will be sent once normal performance has been restored.
Affected services