Circuit Flapping - Concord Region
Resolved
Aug 7, 2026 at 7:54pm UTC
Resolved – Concord Region
The temporary service disruption was caused by maintenance being performed by our fiber provider in the Concord region.
The incident has been resolved, and service has been fully restored. We appreciate your patience during the disruption.
Affected services
Created
Aug 7, 2026 at 7:21pm UTC
Degraded Service – Concord Region
We are currently experiencing intermittent connectivity issues affecting multiple circuits, primarily impacting schools in our Concord region. Several circuits are intermittently going up and down, resulting in periods of network connectivity loss.
Our team is actively investigating the cause of the issue. We will provide an update as soon as additional information becomes available.
Affected services